Kirby Builder example "quote" field doesn't default to edit mode

I am trying out the ‘Kirby Builder’ plugin and using all the default example code.
I come across a problem when adding a Quote: it doesn’t show the edit fields.

The Text and Events fields, work fine. They are in edit mode directly after add.

What do I need to change to get the ‘Quote’ field to also show the edit fields after adding? Maybe I missed a step in the installation?


  • I copied the Kirby Builder code from zip into the /site/plugins/ folder
  • I changed the blueprint of about.yml file from the Kirby starter-kit. I added the fields as in the Example from github. (I deleted the calltoaction: from the last line)
  • I added the code from github to my about.php file
  • I added a folder /snippets/blocks/ and added the file /site/snippets/blocks/quote.php

When I add a Quote, I get an open ‘Quote’ without edit fields. I have to click ‘Edit’ (Wijzig) to show the edit fields.

Extra info:
When I delete the setting defaultView: preview, it will show the edit mode after creation.
so this rule (from the example blueprint) is not implemented it seems:

Newly created blocks ignore this value and have the edit mode or the first tab preselected.

After adding the Quote:

I changed your category because the Plugin category is for announcing Kirby plugins, not for questions regarding plugins.

Thank you!
I also just created an issue for this (what seems to be a) bug.

Hoe can I report a bug for a plugin? I don’t seem to get response on this forum or on the github issue for it.

If I need to make a video of this problem or give more information, please ask. I’m just not able to fix the problem in the code myself.

Thx René .

Usually the developers take care of that. However, Tim has handed over the plugin to the Kirby team and the plan is to integrate the plugin into the core. While this is not done yet, I’m afraid nothing much will happen to the plugin in the meantime.

Good to know,
Thank you for clearing it up for me!