Installation problems (login 404)

I downloaded Kirby as a zip file and unzipped it into a subdirectory (kirby) on a test server. When I point my browser at that folder, I get the “Yay! If you are seeing this…” but every other link is a 404, including the link for panel (“Go to the panel to give Kirby’s admin interface a try.”). When I click on the panel link, it redirects me to "/panel/login " which is not found. Things I’ve tried:

  • Reading the docs … I guess. ht tp:// makes reference to “Please read the installation guide if the panel folder does not exist yet.” … where is this “installation guide?” A page named docs … installation … panel is NOT the installation guide for the panel? When I click on htt p:// I do not see anything like “installation guide” I think a real step-by-step installation guide for Linux/BSD would be a really good idea… unzipping or git cloning is trivial but without a panel, kirby’s no use to me…
  • Made sure that /content and /thumbs and /site/accounts existed and were writeable… in fact I chmod -r 777 kirby
  • Verified that .htaccess was present and that mod_rewrite was enabled
  • Modified RewriteBase to be /kirby and kirby, neither of which changed the 404’s
  • Visited htt p://mydomain/kirby/panel … that just redirects me to htt p://mydomain/panel/login , which doesn’t exist/404
  • Visited htt p://mydomain/kirby/panel/index.php … that just redirects me to ht tp://mydomain/panel/login , which doesn’t exist/404
  • Made the kirby folder it’s own vhost and visited h ttp://kirby.mydomain/panel/index.php and ht tp://kirby.mydomain/panel … again, redirects me to ht tp://kirby.mydomain/panel/login , which doesn’t exist/404
  • Installed via git clone … same problems

Any ideas? I’m frustrated.

Nice, I cannot post more than two links. You’ll have to cut-and-paste them yourselves…

This generally happens when the .htaccess file is not working. It has happened to me in the past when the .htaccess file is present, but the apache configuration was set to not allow overriding anything. Look for a line in the configuration: AllowOverride None and change it to AllowOverride FileInfo

Hope that helps.

Thanks, this WAS the issue. Specifically, I needed to add this block to my vhost (and restart apache):

  <Directory /var/www/html/kirby>
      AllowOverride FileInfo

Thanks again!

This is definitely a bug, as I have followed all the instructions above and installed kirby on a test server running apache to give the platform a test drive and I keep being redirected to:


Sorry my culprit!!! mod_rewrite module was not enabled!! All working now