Input data not saving when using Kirby Page Builder

Tried using Kirby Page Builder but the input data doesn’t get saved after hitting add button. Here’s my blueprint page for the input field :

label: "Contents"
type: builder
    label: Left Text
        label: text
        type: textarea
    label: Right Text
        label: text
        type: textarea
    label: Image
        label: Image File
        type: image
        label: Image Caption
        type: text

The page only gets saved after hitting save on the page, not when hitting the add button.

Ups, i should have add information that i did hit the save button.

Here’s the problem :


When i saved the page, the text files only list a blank input :


Hm, can’t reproduce this, works for me. What Kirby version are you using? Are you using any other plugins/fields?

Our Kirby version is 2.5.5.
I remember we use one plugin called Yakme (not really sure if we use another one)

Yakme has been discontinued. I would consider switching to the Enhanced Text Area.

Do you get any warnings at all in the panel? The times that builder not worked for me, ive had debug messages in the builder area in the panel show up after hitting save. The only fix i could find was to roll kirby back a version.

I tested with Kirby 2.5.7, the last time I used Yakme it worked, but have never tested it with Kirby builder. Please remove Yakme and check if that solves the issue.

An alternative you might want to check out is Kirby SimpleMDE.

I removed everything that’s not Kirby Builder from “Field” and “Plugin” folder but the result still the same.
Tried a fresh Kirby installation and it’s working as intended, any idea what else can affect this ?

Anyway, one thing i noticed is when trying to add “image” the entries doesn’t get updated like when i tried with text input (the one where it got updated but only shows empty box). Might be a clue for something …

Oh, I remember there was an issues with the image field. Guess there is some interference with the Javascript of both fields. Could you try if the issue still persists if you update to 2.5.7?

Oh, it finally works after updating to 2.5.7 ~