Files not deleting Mac

Hi, I have needed to duplicate some folders for backup. When I have needed to remove old KIRBY folders I get an error message saying: ‘You cannot delete because you don’t have permission to access some of the items.’ I have tried using terminal to remove these files with rm -r. This still doesn’t work, how do I delete this?


You could try to set new permissions: sudo chmod -R 755 kirby and then try to delete it in the finder or terminal.

If that doesn’t work, you could try using rm -rf kirby -f means force, which may help. If that doesn’t work either, try sudo rm -rf kirby. Be careful this will delete everything without asking, so make sure to include the correct path.

Hi Thank you for your suggestions, I have tried all 3 this is the message I got back:
rm: illegal option – /
usage: rm [-f | -i] [-dPRrvW] file …
unlink file

Directory not empty

hm, sound like it’s the wrong dash, it should be the “normal” minus sign, maybe it’s some other sort of char, when copied from the forum.