Files Blueprint not recognized

#1

Hi,

I created the following files blueprint at /site/blueprints/files/foto.yml

title: Foto

fields:
  info:
    label: Titel
    type: text
  copy:
    label: Fotograf / Copyright
    type: text

…and added it to my blueprint:

title: Ausflugsbericht
tabs:
  allgemein:
    fields:
      [...]

  fotos:
    preset: files
    template: foto

But no matter whether I open an existing image or upload a new image and open it, on the image page it always says “This page has no blueprint setup yet”.

(When I create a default.yml as suggested at https://getkirby.com/docs/reference/panel/samples/file it shows the text field fine.)

What’s wrong?

#2

I think its the use of the preset. I think you need to either set your own up, or extend the preset instead. Then you can add the template option to it, or override it if has one set already.

#3

Hm, looks like the template option is also ignored if you don’t use the files preset in a tab but as a standard page preset, although the template option is documented in the reference.

#4

@texnixe so do I understand correctly, that you tried other ways but also found no solution to my question?

#5

Yes, I couldn’t make it work, either. It’s either a bug or the docs are not correct.

#6

Issue opened at https://github.com/getkirby/kirby/issues/1778