Can't reach panel after deploying to heroku - 404 error

Hi everyone :slight_smile:

I uploaded my site to heroku (I use it as a staging server) and for some reason I can’t reach the panel. when I enter I receive a 404 error (" Not Found - The requested URL was not found on this server.")

for my last website I did exactly the same thing (uploaded to heroku) and it worked fine with the panel. but with my current site I can’t reach the panel for some reason.

some information that might help:

  • In my local server everything works great, as well as the panel. It happens only after I uploaded it to heroku.
  • not only I can’t reach the panel, It also doesn’t show the images of the site, which I uploaded through the panel when developing (although the textual content is appearing).
  • on github I can see all the content (including the images) in the content folder. so the push is working fine.
  • I read here that there might be some problems with .htaccess but I can’t find it in my kirby folder - maybe this is the cause for the problem? what should I do in this case?

I would really appreciate any help! Thanks in advance :pray:

The problem was solved after I copy pasted the .htaccess from the older project to the new one!