Bug in page visibility if the title contain an number in first position


When you name a project with a number, eg “100 couleurs”, the URL created is just “/couleurs” (stripes the number, not a big deal) BUT, the page became instantly visible, I guess it’s because the name is first changed to “100-couleurs” then the number is striped in the url but the folder has a number before, and so, is visible.

Reproductible by creating a page with a number in the 1st poition of the title.

Tested in kirby 2.3.0

1 Like

This is a known issue, you can’t have titles starting with a number, unless you remove the number from the folder name when creating the page. Another workaround would be to work with two titles.


I managed to create the page with the name 2-100-couleurs by setting the visibility to “2” + manual change of the URL in the panel to “100-couleurs” and it worked.

Well, the problem will still reappear if you try to make the page invisible, though.

OK I see. well, I will adapt.