3.6.0-beta.1 - Languages not showing in backend

I just updated Kirby to the new 3.6.0-beta.1 on a website I’m working on.

The languages work in the frontend - but I can’t see the language option (the button to switch between then & they don’t show in the settings) in the backend.

Nothing has changed in the my config file or in the langages folder…

I have no idea where to look or how to solve this.
Any idea?

Many thanks!

if I downgrade to the languages work also in the backend

Have you removed the media folder and cleared the cache?

I just downloaded a fresh Starterkit, replaced kirby with the beta and enabled languages without any issues and the button is there.

I did, but still not working…

Are you using any Panel plugins (which ones) or custom Panel code? Of course, this could be a Kirby issue or related to some plugin that is not compatible yet.

I’m just using the Kirby Meta Knight SEO plugin and no custom panel code.
Could it be the problem?

I don’t think so. The plugin adds some custom sections, which shouldn’t actually interfere.

If you test with a fresh Starterkit with the beta in your environment, can you reproduce the issue?

I found the problem!

Thanks for your suggestion @texnixe :
with a fresh starterkit the languages where working.
I then tried to add 'languages.detect' => true (as in my project) in the config and the languages stopped working.

Also in my project if I remove 'languages.detect' => true the languages are working well also in the backend.

Is this a known bug? Is there already a way to fix it?

Thanks again!

I couldn’t reproduce the issue with fresh starterkit or demokit on 3.6.0-beta.1.

mmmh, so for you languages.detect is working fine?

Yes as expected.

if it’s my environment to cause the problem - any idea where the issue could come from?

I just enabled languages.detect as well in the Starterkit without encountering your issue.

Thanks everyone for your replies and time.

The cause of the issue is a stupid mistake I had in my code - nevertheless till Kirby 3.5.7 was not a problem, but it is in Kibry 3.6 (for the better I guess).

This was my config file in Kirby 3.5.7:

return [
    'languages.detect' => true

The missing 'languages' => true wasn’t a problem, but in Kirby 3.6 if this is missing the language button disappears from the backend.

This works as expected:

return [
    'languages' => true,
    'languages.detect' => true