Unable to log in or create new user account: Missing handler for type: ""

I am about 90% of the way through my site development but for some reason, my local installation of Kirby has stopped allowing me to log in to the Panel. Having copied the site to the remote server, everything works there fine but my local version just won’t let me log in.

I’m running MAMP 5.5 (Free) on a Mac (OS 10.10.5)

When I try to login I get the shaking of the password box like I’ve entered the incorrect password but if I check the console it’s actually returning an error.

POST http://localhost:8888/gatehouse/api/auth/login 500 (Internal Server Error)

{status: "error", exception: "Exception", message: "Missing handler for type: """, file: "gatehouse/kirby/src/Data/Data.php", line: 71, …}
code: 500
exception: "Exception"
file: "gatehouse/kirby/src/Data/Data.php"
line: 71
message: "Missing handler for type: """
route: "auth/login"
status: "error"
__proto__: Object

I have tried deleting all user accounts and creating a new one but I simply get a modal popup that reads ‘Missing handler for type: “”’ when I submit the form to create a new account.

Sometimes, I can load the login page and get no form at all, just ‘Missing handler for type: “”’

I have also tried deleting all session data.

Other things I have tried:

  • Downloading the working good version from the server. Same result
  • Duplicating the to a different subfolder. Same result.
  • Restarting MAMP, browsers and Mac. Same result.
  • Updating MAMP to latest version. Same result.
  • Tried multiple browsers. Same result.
  • Overwrite contents of “kirby” directory. Same result.
  • Reset .htaccess file. Same result.
  • Downloaded and set up Kirby Starterkit. Works fine.

Just to reiterate - it was all working absolutely perfectly and just stopped working.

The site still displays and functions perfectly, it’s just the Panel that is inaccessible.

Does anyone have any ideas? I’m at the end of my understanding!

I could just finish the development on the remote server but it’s a real pain compared to working locally.

Watt I would try is download a Plainkit, see if it works, and then copy the stuff from your project into it (content, site, assets, etc.)

I’ve haven’t seen this error before.

Hmmm, on a hunch I wondered if the action of syncing with the server had somehow created some mysterious hidden file (I’m using Dreamweaver).

I went through my duplicated install, removing all the hidden files/folders I could find and then tried logging in again.

Hey presto, it worked.

I’ve never seen anything like this before. I guess it might be time to stop using Dreamweaver…

Good idea. I’d recommend VS Code.

I’ve actually just been looking at that!

[hits download]