Typing and it deletes in seconds

In case we are on the wrong track:

  1. What Kirby version are you using?
  2. Are you using virtual pages?

Kirby version 3.2.2
No virtual pages (not sure what they are)

Virtual pages are pages that do not exist in the file system but are created from other data, like a database, an API etc.: https://getkirby.com/docs/guide/virtual-pages

Ahhh right, then no. None of those

Still nothing from hosting provider’s support?

No sadly. I’m using DigitalOcean and they aren’t exactly the fastest when it comes to support sadly :frowning:

I face the same problem and I did check my write permissions, it still doesn’t seem to work for me.

Are you getting any errors in the console?

Are you on DigitalOcean as well? And do you get the same error message or is it just the same effect?

I’m experiencing the same exact behavior on a DO droplet as well. It’s an ubuntu 18.04 LAMP config.

I’m on 3.2.3.

Hm, what if you create a route in your config like this:

    'routes' => [
            'pattern' => 'mytestroute',
            'method' => 'PATCH',
            'action' => function() {
                return ['all good'];

And send a PATCH request via some tool like RESTED (e.g. for firefox: https://addons.mozilla.org/en-US/firefox/addon/rest-easy/)

@texnixe, I tried what you outlined above using ARC (chrome extension) and got the same (ok) response. So I think it’s allowing those requests.

I dug in a little deeper and noticed that the content I as having an issue with was one specific blog post/folder. Turns out, I had uploaded it via SFTP with a different user that had different permissions.

Updating the user of that folder cured this problem for me.

@Suleiman_Leadbitter, consider looking into how users have been set up on your droplet. Might be related to your issue.

1 Like

Check your write permissions for /content , /media , /site folders and subs.

sometimes following this steps i still get the same problem.

@JackRyan404 Hm, are you using any custom code? I have seen the same effect for example when doing quick and dirty dump() debugging.