The panel assets cannot be installed properly

Thanks for that. I tried it and then went to domain/panel and it says the same thing. It also did not recreate the folder. - this has me fairly stumped.

Hm, maybe it’s not so much a permissions than a file owner problem?

I checked that and the owner is the correct user. :cry:
I don’t know if it is relevant but the links to all the images in test site are broken - but sub pages work.

Is that on localhost or remote?

Remote (BTW your support rocks).

Well, usually, if I remove the media folder, Kirby auto-recreates it. So I think there must be a problem with the write rights in general.

What is your environment, hosting provider?

Google cloud, Ubuntu 18.0.4 Apache 2.4.29, php 7.2

Hm, I’m not familiar with Google cloud but wondering if that’s really made for writing stuff?

I think it is the same as AWS or any host - just VM server instances.

Have you tried to temporarily give 777 permission for testing?

1 Like

You are a genius. Thanks so much - that worked. I was not thinking clearly!!

Well, ok, but you shouldn’t use those settings because of security problems. However, that makes me think that your Apache user is not correct, usually should be www-data (depending on server settings)

1 Like

Yeah I realize they are terrible for security. I am just using this as a test/dev instance to see if it will work for our needs. I will have someone more experienced that myself do a proper install should we go with it. I will look into the apache user.

1 Like

I am seeing this same issue, if i delete the folder, then it gets recreated and a subfolder ‘panel’ appears as well, but then it stops with the same error as above.

Worth noting that the site itself runs OK, the problem just seems to be with the panel, tried messing about with the RewriteBase too.

I’ve had the same issue, turned out it was a totally different problem, my composer.json file was missing in the kirby folder.

It was hard to find that out because the application just dies in /kirby/src/Cms/Panel.php on line 69:

die('The panel assets cannot be installed properly. Please check permissions of your media folder.');

I commented out that line because I was sure all my permissions were set correctly. After that, the debugger kicked in and tracing the error was much easier.

I’ve seen that quite a few people had trouble with this. Maybe would be an idea to not let the app die in that moment?

4 Likes

Does that mean composer.json shall be deployed to a production web site!?

That does not look clean to me but it seems necessary.

It’s not a major security risk but anyway, some.

Can you confim this?

I don’t see a connection between composer.json and the problem described above? And why exactly should composer.json be a security risk?

I can confirm this. Just had this issue where I couldn’t access the panel on a newly deployed website.

The panel assets cannot be installed properly. Please check permissions of your media folder.

I’ve spent hours on this, talked to the server company who said the permissions were ok, but they tried to make some changes with no luck.

Then I stumbled upon this thread that talks about a missing composer.json file.

In my deploy settings, all composer.json files are ignored. But if change this so all composer.json files are deployed, the error message is gone, I can access the Panel.

This sounds like a good idea.

The problem is indeed in composer.json. When linking the panel assets folder with the media folder, Kirby generates a hash of its version here, and that version is read from Kirby’s composer.json here.

No composer.json means no verson, no hash, and an error when initializing the panel assets.
I opened an issue on GitHub for this.

The composer.json issue will be fixed in Kirby 3.4.0, see https://github.com/getkirby/kirby/issues/2507.