Prevent date field autofocus in structure field

This is technically not a bug but quite annoying in my case:

I have a structure field that contains a date field as first child. When clicking on an existing entry, the date field pops up and it is necessary to confirm the date in order to close the overlay. Clicking elsewhere on the structure does nothing and clicking outside of the structure closes everything.

Is it possible to prevent this autofocus behaviour. Ideal would be a field property like autofocus: false but maybe there’s a workaround?

There is an autofocus property for all fields.

I’ll be damned! I was sure I checked that.

In any case it doesn’t seem to help. I believe the issue is that it depends where you click on a structure entry. When you click on a field in the table view, it gets selected irrespective of its autofocus setting. See example (with autofocus:false on the date field):

And if you set autofocus to false on the complete structure?

label: Events
type: structure
sortBy: date asc
autofocus: false
fields:
  date:
    extends: fields/date
    required: true
    autofocus: false

Still not working :cry:

Hm, too bad… Then I don’t know. Create an issue on GitHub?

Will do. Thank you!

See: [Panel] Blueprint autofocus property not working as expected · Issue #3083 · getkirby/kirby · GitHub