# PHP startup error

**URL:** https://forum.getkirby.com/t/php-startup-error/6437
**Category:** Questions
**Tags:** v2
**Created:** [January 28, 2017, 10:56am UTC](https://forum.getkirby.com/t/php-startup-error/6437 "2017-01-28T10:56:25Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![ikyriazi](https://avatars.discourse-cdn.com/v4/letter/i/d78d45/32.png) [@ikyriazi](https://forum.getkirby.com/u/ikyriazi)
#### Post date: [January 28, 2017, 10:56am UTC](https://forum.getkirby.com/t/php-startup-error/6437/1 "2017-01-28T10:56:25Z")

</div>

Hello!

I have moved my site (local server) from Kirby 2.4 to 2.4.1 and I have also installed the new MAMP version in my new Mac (Version 10.12.2).

When trying to log in into my panel (or logout) I get the following error message:

PHP Startup: Unable to load dynamic library ‘/Applications/MAMP/bin/php/php7.1.0/lib/php/extensions/no-debug-non-zts-20151012/pdo\_pgsql.so’ - dlopen(/Applications/MAMP/bin/php/php7.1.0/lib/php/extensions/no-debug-non-zts-20151012/pdo\_pgsql.so, 9): image not found

(I re-downloaded and installed the PHP 7.1 version from the MAMP site, in case it would fix the problem, but it didn’t.)

Sometimes by re-clicking [return] in the URL address in my browser, I manage to log in (but still this is not how it should be)  
I noticed also that I have problem with uploading photos in my projects page. When I click on “open” in the files window, there is no reaction and the file is not uploaded (could it be related, or is it another issue?)

Do you have a suggestion on how to solve this?

Thanks, Ilias

---

<div class="post-metadata">

### Author: ![ikyriazi](https://avatars.discourse-cdn.com/v4/letter/i/d78d45/32.png) [@ikyriazi](https://forum.getkirby.com/u/ikyriazi)
#### Post date: [January 28, 2017, 5:08pm UTC](https://forum.getkirby.com/t/php-startup-error/6437/2 "2017-01-28T17:08:47Z")

</div>

Update:

I downgraded my MAMP version to 3.5.2 and now it seems to work fine.  
I also have no problem with uploading photos.

---

<div class="post-metadata">

### Author: ![texnixe](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/texnixe/32/5754_2.png) [@texnixe](https://forum.getkirby.com/u/texnixe)
#### Post date: [January 28, 2017, 5:17pm UTC](https://forum.getkirby.com/t/php-startup-error/6437/3 "2017-01-28T17:17:32Z")

</div>

I’m running Mamp Pro 4.0.6/PHP 7.1.0 on a Mac with macOS 10.12.2 without any problems.

Edit; Check if the file /Applications/MAMP/bin/php/php7.1.0/lib/php/extensions/no-debug-non-zts-20151012/pdo\_pgsql.so exists in that location.

---

<div class="post-metadata">

### Author: ![ikyriazi](https://avatars.discourse-cdn.com/v4/letter/i/d78d45/32.png) [@ikyriazi](https://forum.getkirby.com/u/ikyriazi)
#### Post date: [February 1, 2017, 12:48pm UTC](https://forum.getkirby.com/t/php-startup-error/6437/4 "2017-02-01T12:48:04Z")

</div>

If I remember well, it was not there. As I said, I have downgraded to Mamp 3.5.2 and it now works fine. I guess, I will stay with this version for now. Thanks though for your help!

---

<div class="post-metadata">

### Author: ![distantnative](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/distantnative/32/11319_2.png) [@distantnative](https://forum.getkirby.com/u/distantnative)
#### Post date: [February 6, 2025, 4:52pm UTC](https://forum.getkirby.com/t/php-startup-error/6437/5 "2025-02-06T16:52:49Z")

</div>


