# Panel login fail on new production server

**URL:** <https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191>\
**Category:** Questions\
**Tags:** v2\
**Created:** [August 8, 2019, 1:41pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191 "2019-08-08T13:41:17Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![itWilllBeOK](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/itwilllbeok/32/444_2.png) [@itWilllBeOK](https://forum.getkirby.com/u/itWilllBeOK)\
**Post date:** [August 8, 2019, 1:41pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191/1 "2019-08-08T13:41:17Z")

</div>

When I move a localy yworking 2.5.12 site to the production server, I can’t log into the panel anymore. When I enter name/password, I just get redirected to the login screen. No error message or anything.  
Same thing happens, when I delete accounts and try panel/install - I enter user data and get redirected to the same screen.

Any idea, how this could happen on one server, but same site on local and other remote server are ok?

---

<div class="post-metadata">

**Author:** ![carstengrimm](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/carstengrimm/32/188_2.png) [@carstengrimm](https://forum.getkirby.com/u/carstengrimm)\
**Post date:** [August 8, 2019, 1:43pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191/2 "2019-08-08T13:43:50Z")

</div>

very often, my login / sessions fail, when not using SSL.

or when jumping between http and https

---

<div class="post-metadata">

**Author:** ![itWilllBeOK](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/itwilllbeok/32/444_2.png) [@itWilllBeOK](https://forum.getkirby.com/u/itWilllBeOK)\
**Post date:** [August 8, 2019, 1:46pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191/3 "2019-08-08T13:46:04Z")

</div>

neither use case has SSL. could there be a case where a certain server configuration could cause this issue?

---

<div class="post-metadata">

**Author:** ![texnixe](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/texnixe/32/5754_2.png) [@texnixe](https://forum.getkirby.com/u/texnixe)\
**Post date:** [August 8, 2019, 1:51pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191/4 "2019-08-08T13:51:33Z")

</div>

Hm, have you tried to clear your browser cache? Also, make sure there is no `.logins` file on the server in the `/site/accounts` folder.

---

<div class="post-metadata">

**Author:** ![itWilllBeOK](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/itwilllbeok/32/444_2.png) [@itWilllBeOK](https://forum.getkirby.com/u/itWilllBeOK)\
**Post date:** [August 8, 2019, 1:54pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191/5 "2019-08-08T13:54:10Z")

</div>

no cache.  
deleting `.logins` doesn’t help.  
already tried deleting the accounts folder and create new account via `install`, but that creat-user form shows same pattern: enter data, redirect to form with no error message

---

<div class="post-metadata">

**Author:** ![texnixe](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/texnixe/32/5754_2.png) [@texnixe](https://forum.getkirby.com/u/texnixe)\
**Post date:** [August 8, 2019, 2:05pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191/6 "2019-08-08T14:05:57Z")

</div>

And you file and folder permissions are OK as well, as well as ownership of the files and folders?

Anything in your php error logs?

---

<div class="post-metadata">

**Author:** ![itWilllBeOK](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/itwilllbeok/32/444_2.png) [@itWilllBeOK](https://forum.getkirby.com/u/itWilllBeOK)\
**Post date:** [August 8, 2019, 2:23pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191/7 "2019-08-08T14:23:45Z")

</div>

Re permissions: I just turned on caching to see if any files are generated, and they are. so I guess permissions are fine?

nothing in the error logs. also debug says nothing.

---

<div class="post-metadata">

**Author:** ![texnixe](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/texnixe/32/5754_2.png) [@texnixe](https://forum.getkirby.com/u/texnixe)\
**Post date:** [August 8, 2019, 2:28pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191/8 "2019-08-08T14:28:11Z")

</div>

What about `www` vs `non-www` does it work with one of them?

---

<div class="post-metadata">

**Author:** ![itWilllBeOK](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/itwilllbeok/32/444_2.png) [@itWilllBeOK](https://forum.getkirby.com/u/itWilllBeOK)\
**Post date:** [August 8, 2019, 2:34pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191/9 "2019-08-08T14:34:21Z")

</div>

non does. i did have the redirect to www in the htaccess, but already took it out.

i have no access to the server config or any logs (i know, right), but right now the server person is having a look. but i suspect so far they don’t have a clue either.

---

<div class="post-metadata">

**Author:** ![carstengrimm](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/carstengrimm/32/188_2.png) [@carstengrimm](https://forum.getkirby.com/u/carstengrimm)\
**Post date:** [August 8, 2019, 2:56pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191/10 "2019-08-08T14:56:09Z")

</div>

you could also do a test on another server to see if the issue is solely related to the server??

---

<div class="post-metadata">

**Author:** ![itWilllBeOK](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/itwilllbeok/32/444_2.png) [@itWilllBeOK](https://forum.getkirby.com/u/itWilllBeOK)\
**Post date:** [August 8, 2019, 3:41pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191/11 "2019-08-08T15:41:01Z")

</div>

OK, solved.

The hoster has some kind of strict cookie policy. They dialed it back a bit, now it’s working.  
Will post details when I have them.

Thanks so much though y’all for caring! Really helped me to stay calm!  
🥰

---

<div class="post-metadata">

**Author:** ![distantnative](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/distantnative/32/11319_2.png) [@distantnative](https://forum.getkirby.com/u/distantnative)\
**Post date:** [February 6, 2025, 5:23pm UTC](https://forum.getkirby.com/t/panel-login-fail-on-new-production-server/15191/12 "2025-02-06T17:23:13Z")

</div>


