Page not displaying due to some text on the page

Hello, I just ran into an issue where my sub-page doesn’t render nor does the parent page it’s nested under due to some text that is in my story. Kirby seems to have a problem with the text below, specifically the part that says, “C_0-semigrops…” I removed this word and the page finally displayed. When I placed it back the page didn’t render again.

Any ideas?

Dr. Marat Markin’s (Mathematics) paper, “On the generation of Beurling type Carleman ultradifferentiable C_0-semigrops by scalar type spectral operators,” has recently appeared in the (link: text: Methods of Functional Analysis and Topology Journal) published by the Institute of Mathematics of the National Academy of Sciences of Ukraine.

Which Kirby version/server type/PHPversion are you using?

I am using the latest version 2.4.0 and running XAMPP with Apache and PHP v5.6.28.

Do you have the same problem on your remote server?

I can’t replicate the problem on the remote server. It works fine there but now I see that the email addresses are not resolving to the standard on my local machine or on the remote server.

The email addresses throughout the site are encoded like such:

Yes, this email issue is a bug. It’s already been solved on the development branch and will be in the next release. In the meantime, you can download the developer branch from GitHub or if you use the Kirby CLI, run

kirby update --dev

As regards the character issue on Windows, I have no idea what could be causing this…:thinking: Is it the underscore that’s causing this?

Thanks, I updated Kirby to the latest. Unfortunately the character issue is still present on Windows using XAMPP. I narrowed it down further and there seems to be an issue with underscores within a quote. It’s odd. The remote version has no problems.

Could this be related to Markdown Extra?

Do you have Markdown extra enabled? But I don’t see how this could result in the page not rendering at all. Have you tried to escape the underscore?

No, Markdown extra isn’t enabled. Escaping the underscore works fine. I guess I’ll just have to remind users who input our content to escape the underscore whenever they publish content like that.

Thanks @texnixe

Maybe it helps if you enable Markdown extra, have you tried that?

Yea, I’ve tried that. Unfortunately it doesn’t work.

Will editors work on localhost using Xampp?

No, ultimately they will be using it on the remote server but I was going to provide the initial training to them on a local machine running XAMPP. I’ll just use the remote server and private directory instead.