Missing panel, and images

Hi, I recently deployed to a staging server for the first time, and the site runs except there is no Panel, the directory “/panel/” is a 404. Also no images are showing up. Not sure what I’m doing wrong. This is the staging url: http://philb12.sg-host.com/

Welcome to the forum, @philb5000! A few questions to help us guide you:

  1. do you have the site setup in your local computer, and it’s fully working locally?

  2. did you upload the /kirby, /media, and all other folders to the staging server? When you login to the server via SFTP/SSH, do you see those folders there? Do they have the same content you have on your local computer?

  3. did you change the name or location of the ‘panel’, ‘content’ or ‘media’ folders from their default, in your setup? - ie., changing them in the config and/or htaccess file?

1 Like
  • If your server is an Apache server: Have you uploaded the .htaccess file to the server? Is the server configured to allow .htaccess overwrites?
  • Is rewriting enabled?
  • If you are on Nginx: what does your configuration look like?
1 Like

Thanks! @kirbyzone :slight_smile: Okay going through these three:

  1. yup, working well on Local
  2. Yes, i uploaded those folders and I can see them there in the FTP
  3. No, i didn’t change any folder names.

So i’m not sure what’s going on. Though I don’t really understand my server setup – still learning about it. Will check out @texnixe 's questions too

Thank you!

@texnixe - thanks! Okay the headers say “nginx” but Siteground says they use both?’?

So I’m not sure if I need a htaccess or some other config for the server, to be able to serve images and see the panel

The web server is an Apache then, I think.

What you can try:

  • put some rubbish into the .htaccess, if you then get a 500 error, you know that your .htaccess is at least read
  • Then check out the admin panel of your hosting if you can find anything related to rewriting
1 Like

thanks @pixelijn - will try!

@pixelijn - Hmm the Htaccess file isn’t being read at all. I’m chatting with Siteground to see what I can do about it.
Weirdly the reason the images aren’t loading is because they’re in odd /media/ subfolders that don’t exist or something. It runs fine on my local so I’m still not sure what’s going on

Okay the host helped me flush the cache, and add the proper .htaccess file – it appears that was the issue! Seems to work now. http://philb12.sg-host.com/

Thank you to all who responded.

1 Like