# Migration to live server failed

**URL:** <https://forum.getkirby.com/t/migration-to-live-server-failed/25042>\
**Category:** Questions\
**Tags:** v3\
**Created:** [March 21, 2022, 2:13pm UTC](https://forum.getkirby.com/t/migration-to-live-server-failed/25042 "2022-03-21T14:13:42Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![teh](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/teh/32/9669_2.png) [@teh](https://forum.getkirby.com/u/teh)\
**Post date:** [March 21, 2022, 2:13pm UTC](https://forum.getkirby.com/t/migration-to-live-server-failed/25042/1 "2022-03-21T14:13:42Z")

</div>

Hi there,

I’m working with Kirby a lot, however I don’t know how to fix this, maybe someone has an idea.

I’m trying to migrate/copy a finished dev version to another live server, however it doesn’t work. My guess, due to PHP reasons.

The standard PHP version on the company’s servers is `7.2`, however Kirby needs at least `7.4`, so I changed it in the company’s server settings. But after I changed it, I saw this auto-added line inside the Kirby `.htaccess` file at the very top: `AddHandler php-fastcgi7.4 .php .phtml`

So having this new line, the Kirby `.htaccess` file apparently doesn’t work anymore –\> the website shows an empty page. If I delete the line, the server reverts to PHP `7.2` and shows the custom Kirby error message since it needs `7.4`.

I already tried the usual common culprits ie.  
• changing the `RewriteBase` paths  
• checking `mbstring`  
• checking `mod_rewrite`  
• deleting `media` or `cache` folder  
• tried PHP `8`  
to no avail.

(A regular root-level `test.php` test file works)

Thanks for any tips!

---

<div class="post-metadata">

**Author:** ![teh](https://dub1.discourse-cdn.com/flex017/user_avatar/forum.getkirby.com/teh/32/9669_2.png) [@teh](https://forum.getkirby.com/u/teh)\
**Post date:** [March 21, 2022, 2:48pm UTC](https://forum.getkirby.com/t/migration-to-live-server-failed/25042/2 "2022-03-21T14:48:23Z")

</div>

Question can be marked as solved or even deleted, works now. Some of the dev files got corrupted during copying to the live server via ftp. 🙄
