Kirby 3 – "The string did not match the expected pattern"

panel

#1

In the modal window, when adding a page and afterwards clicking on the status circle, I’m getting the “The string did not match the expected pattern”-error. If the title of the added page is only numbers though, the error doesn’t appear.

Any ideas why?

Thanks!


#2

Could you post the relevant blueprint, please? Anything else in your console?


#3

The site.yml blueprint:

title: Übersicht

options:
  url: false
  status: false
  delete: false
  changeTitle: false

columns:
  - width: 1/3
    sections:		            
      startseite:
        headline: Anderer Content
        type: pages
        templates:
        	- home
        	- services
        	- markets
        	- aboutus
        	- contact
        	- press
        	- legal
        	
  - width: 1/3
    sections:		            
      productcategories:
        headline: Produktkategorien
        type: pages
        template: productcategory
	 
	- width: 1/3
	  sections:		            
	    news:
	      headline: News
	      type: pages
	      template: newsitem

The productcategories-column is the one, that throws the error.

The productcategory.yml blueprint:

title: Produktkategorie

options:
  url: false

I found out, that if I use num: num inside the productcategory.yml blueprint, the error does not occur.


#4

Hm, I can’t reproduce this. Is that all that is in your productcategory.yml?

On a side note: The options in your site.yml blueprint (apart from changeTitle) don’t really make sense, you might as well remove them.


#5

Hm, ok. Yeah, that’s all in the yml, for testing.

Thanks for the options-hint!


#6

Hm, anything else that could be causing this? Hooks, plugins?


#7

Wild guess: are you by chance on mac and using codekit?

Asking because there was a similar-ish issue in another thread and the issue turned out to be related to the codekit urls


#8

Ah, no, but maybe it’s Safari-related. Thx!


#9

I just tried your code and everything seems to work just fine for me as well so maybe it’s something related to your environment


#10

Yeah, maybe, thanks anyways!