Installing K3 testing with MAMP Whoops \ Exception \ ErrorException (E_ERROR)

Hi, I am just doing a basic install for testing with MAMP and i get the following error

Whoops \ Exception \ ErrorException (E_ERROR)

Uncaught Whoops\Exception\ErrorException: preg_match(): JIT compilation failed: no more memory in /Applications/MAMP/htdocs/starterkit-master/kirby/vendor/filp/whoops/src/Whoops/Exception/Frame.php:58

If i do the install on the panel then I got

The section “albums” could not be loaded: preg_match(): JIT compilation failed: no more memory

It seems the problem is with Php 7.3
I change to php 7.2 and it is working

Wonder if that is a missing or ill configured PHP module. Check your php.ini for pcre.jit setting. Never seen that error before.

I just had a similar error after updating MAMP to 5.3:

Whoops\Exception\ErrorException thrown with message “preg_replace(): JIT compilation failed: no more memory”

When it’s set to PHP 7.3.1 it shows the Error.
PHP 7.2.14 works fine.

When I search for pcre.jit in php.ini of PHP 7.3.1 I find this:

;Enables or disables JIT compilation of patterns. This requires the PCRE
;library to be compiled with JIT support.

Did I do something wrong or should I just work with PHP 7.2 ?

Thanks for any tips !

I used Mamp myself until yesterday and haven’t run into this issue yet, with none of the 7.1+ PHP versions (Mamp 5.3/OS X Mojave).

When exactly does this error occur? Any steps to reproduce?

There is a bug report with this problem re. PHP 7.3

Seems that a temporary fix would be to set


in PHP.ini according to this SO thread.

Yes, with pcre.jit=0 it works ! Tanks a lot

Just had the same problem with XAMPP-7.3.8-2. Fixed by adding pcre.jit=0 to php.ini.