How to regenerate thumbnails

Hi,

I have implemented webp but now there is “crop-1” in the url. How can I get rid of the “-1”? I have already deleted my cache and media folder.

Example:
It used to be:

podcast-about-coffee-350x235-crop.jpg

and now its like this:

podcast-about-coffee-350x235-crop-1.webp

Does anyone how I can remove the -1 from the url?

Thanks!

I wonder where the -1 is coming from? Can’t reproduce this in a Starterkit. Are you using Kirby 3.6?

When I crop with webp format:

<?= ($cover = $project->cover()) ? $cover->thumb(['width' => 400, 'height' => 500, 'crop' => 'center', 'format' => 'webp']) : null ?>

I get for example island-from-above-400x500-crop.webp.

Yes! I am using Kirby 3.6.1.1.
It’s very strange but -1 remains in the name.

Edit: Seems to happen when you set crop to true, vs setting crop to center.

1 Like

Yes that’s the problem. Strange!

From which version did you update?

Version Kirby 3.4.3

I’d suggest that if you use 'crop' => true, replace it with 'crop' => 'center' which is the default value for crop.

1 Like

Thank you @texnixe! This makes it more clear to me, it has indeed solved it :slight_smile: