Future support for Kirby 2 (PHP 7.3+)

#1

Hey everyone,

we still get asked quite often about the support for Kirby 2 and we know that it is not always feasible to update older sites to v3. We said with the launch for v3 that we are going to keep supporting v2 with security updates at least until December 2019. Most likely longer than that – depending on requests.

We just updated our test setup to test v2 against PHP 7.3 and all tests pass. This is important as the PHP versions are moving forward quickly and we want to make sure that you can run Kirby on modern PHP versions for security and performance reasons.

We also decided that we are no longer going to run tests again PHP 5.x versions and we will no longer support them officially. Their lifetime has ended months ago and the PHP core team is not supporting those versions anymore. Running websites on such older versions is a risk and you should urge your hosting providers or sys admins to update their servers if they haven’t done that yet.

If you are looking for the source code or docs for v2 you can find them here:


We no longer sell v2 licenses, but you can get a v3 licenses and we will help you to convert it to a v2 license key. Get in contact for such cases: support@getkirby.com

Please let us know if you have any additional questions!

Cheers,
Bastian

2 Likes