Can't edit things through the panel and permissions problem in a VPS

##User permissions problem in a VPS with WHM (cPanel)

The user permissions problem happened on two different servers (VPS) with WHM and cPanel. Since this problem was beyond my server administration knowledge and had already tried many things I asked for support on the two different hosting providers.

MediaTemple gives only complimentary support, they charge for it so they didn’t really help much. The second provider is ServInt. I find their support very timely and helpful, they’ve saved my ass a couple of times with their answers. Please note that I have no affiliation with them, I’m just a happy customer.

After uploading everything, and finishing the panel installation, the applications asked for the correct user permissions on the “content” folder. Setting everything to “755” for content directories and “666” for files did not work, so I asked for support. This is one of their answers:

I highly recommend installing mod_ruid2 so that all PHP processes are running as the domain owner. This way, a standard, secure permission scheme can be applied to all of your accounts which not only minimizes vulnerability but also ensures proper write operations for files. I have personally installed this module on many server with successful results regarding permission related issues.

And that totally solved it. It seems that some default settings for WHM with the PHP handler created some troubles with my Kirby installation.

##Improper changes being made by the panel

Ok, the main saving problem was all due to mbstring not being correctly installed. To be honest I totally forgot I had to install that one, I must have had that one on on my local server and didn’t notice about it. Consider the following post for further reference: