Can’t unlock a page in Firefox

Hi there, we just discovered that you can’t unlock a page in the panel with Firefox – the text button seems to be inactive. Safari though works fine.

Kirby version: 3.2.0
Firefox version: 69.0b9

Is that on Windows? My Mac FF works fine.

Or a beta FF? My version is 68.0.1 and it’s up to date.

Mine is on macOS Mojave 10.14.6. The same error happens on my wive’s MacBook Air: Same OS, same Kirby, but FF 68.0.1 – the same as yours. Strange.

PS My FF is the Developer Edition, which seems to be one version ahead.

Ok, I can reproduce it now. Could you please create an issue on GitHub?

But maybe we should test with the latest version 3.2.3 first.

Hm, now the unlock suddenly was active again…

I’ll ask Sascha to update this server to 3.2.3 and then check again.

I also tested with Chrome and 3.2.3 now, with the same effect that is takes much more than the default 2 minutes until the unlock button gets activated. Something is strange.

A short update: after the update to Kirby 3.2.3 the button became active in all three browsers (FF, Safari, Chrome). Not the same result as in your tests but maybe worth a look of the core team since page locking (and unlocking) is a tent pole feature of the very recent development. THX Sonja – as always.

I’m seeing the same issue in Safari. We have four admins, and when we all get in there, we often see the “Locked” state for no apparent reason (no changes made by any user).